Content in category 技术笔记

Samba 配置手册

在 CentOS 7 中使用 yum 安装 Samba yum install -y samba samba-client Samba 的配置文件在/etc/samba/smb.conf 配置说明如下: # 定义全局的配置 [global] # 可选设置。让你使用另一个配置文件来覆盖默认的配置文件。如果文件不存在,则该设置无效 # 这个设置可以使 Samba 的配置更灵活,能够让一台 Samba 服务... ▿展开全文

配置 vsftpd 搭建 FTP 服务器

常用命令: # 安装 vsftpd yum install -y vsftpd # 检查|启动|停止|重启 vsftpd 服务 service vsftpd status|start|stop|restart # 设置开机自启动 systemctl enable vsftpd.service # 让防火墙开启 FTP 服务和 21 端口的使用 firewall-cmd --add-service=ftp --permanent firewall-cmd --add-port=21/tcp --permanent firewall-c... ▿展开全文

安装完最小化 CentOS 7 后需要做的一些事情

CentOS 是一个工业标准的 Linux 发行版,是红帽企业版 Linux 的衍生版本。你安装完后马上就可以使用,但是为了更好地使用你的系统,你需要进行一些升级、安装新的软件包、配置特定服务和应用程序等操作。 参考来源 以下事情全都做完后,就可以让 Nginx 作为 HTTP 服务,让 MariaDB 来替代 MySQL 作为数据库,建立 FTP 以及 SMB 来... ▿展开全文

CentOS 安装 Vim

安装了 CentOS 最精简版本的话,自带的 Vim 编辑器功能很简陋,连代码高亮都木有。所以需要安装一个新的 Vim 来代替它。 先执行以下命令来查询 CentOS 上的 Vim 是什么版本: rpm -qa|grep vim 如果只有一个 vim-minimal,那就需要我们装功能更完善的 Vim了。执行以下命令即可: yum -y install vim* 安装完后,再执行一边查询命... ▿展开全文

CentOS 提示用户名不在 sudoers 文件中的解决办法

为了安全起见,平时在 CentOS 中进行进行操作的时候并没有直接用 root 这个超级管理员帐号,而是自定义了一个帐号在对服务器进行操作。有一次发现在以 root 身份执行命令,输入sudo xxxx的时候,提示我XXX 不在 sudoers 文件中。 解决办法就是在sudoers文件中添加我们自定义的帐号,并赋予相关权限: # 用 vi 编辑器打开 sudoers ... ▿展开全文

CentOS 7 用 yum 安装 Nginx

在 CentOS 7 中,直接使用 yum 安装 Nignx 会提示无下载源。因此,需要添加 Nginx 的下载源到 yum: sudo rpm -Uvh http://nginx.org/packages/centos/7/noarch/RPMS/nginx-release-centos-7-0.el7.ngx.noarch.rpm 指定了下载源后,就可以使用 yum 命令来安装 Nginx 了: sudo yum install -y nginx 安装完成的 Nginx 并不会立刻... ▿展开全文

CentOS 7 的防火墙开启 http 80 端口

在虚拟机 CentOS 7 上装了 Nginx,结果发现另一台电脑无法访问其默认页面,通过 telnet 192.168.1.88 80 监听发现是 http 80 端口被 CentOS 7 的防火墙 Firewalld(CentOS 6 的防火墙是 iptables)给阻止通信了。 接下来就讲下如何添加防火墙规则。 先查看防火墙是否开启的状态,以及开放端口的情况: systemctl status firewalld... ▿展开全文

密码保护:CentOS 7 安装 ShadowSocks 客户端

首先需要确认 CentOS 7 上的 Python 是否装有 pip,如果没有装 pip,则先进行下面的步骤: # 检查是否有装 pip pip list # 没装 pip 则执行以下命令 curl "https://bootstrap.pypa.io/get-pip.py" -o "get-pip.py" python get-pip.py 装好 pip 以后,开始安装 ShadowSocks: pip install shadowsocks 安装完 ShadowSocks,创建一... ▿展开全文

pip 出现警告提示:The default format will switch to columns in the future

我在升级安装了 pip 9.0.1 后,查看 pip list 的时候出现了警告提示: DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning. 这个其实就是告诉你以后版... ▿展开全文
 

© 2017 老柴的宅. Powered by Chaishiwei.com. 鄂ICP备11006811号